Document upload and download may be failing for some users
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Apr 25, 2024 - 15:34 UTC
Identified
During the process of maintenance there was a problem with the upload pool, we are currently working towards implementing a fix.
Posted Apr 25, 2024 - 15:11 UTC
This incident affected: CLM (UAT).