Customers may experience issues loading workflow reports
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 23:23 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jan 19, 2023 - 23:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 19, 2023 - 23:01 UTC
This incident affected: CLM (NA11, NA21).