Some customers may see errors when signing
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Jan 29, 2023 - 18:01 UTC
Investigating
We are currently investigating this issue.
Posted Jan 29, 2023 - 17:44 UTC
This incident affected: TSP EU (EU Trusted Service Provider).