Customers may experience latency on NA1/NA4 between 18:00 UTC and 18:06 UTC
Incident Report for DocuSign
Resolved
Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted May 24, 2023 - 21:51 UTC
Update
We have registered another occurrence from 19:02 UTC to 19:08 UTC.
Posted May 24, 2023 - 19:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 24, 2023 - 18:39 UTC
This incident affected: eSignature (NA1, NA4).