Customers may experience delays using the document search tool
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 23:00 UTC
Update
We are continuing to investigate this issue.
Posted Jan 19, 2023 - 23:00 UTC
Investigating
We are currently investigating this issue.
Posted Jan 19, 2023 - 20:41 UTC
This incident affected: CLM (NA11).