Customer issue in PSM production
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 15:07 UTC
Investigating
We are currently investigating this issue.
Posted Jan 26, 2023 - 14:55 UTC
This incident affected: TSP EU (EU Trusted Service Provider).