Customers may have seen latency in signing documents in NA1
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Jan 30, 2023 - 19:57 UTC
Investigating
We are currently investigating the issue
Posted Jan 30, 2023 - 19:25 UTC
This incident affected: eSignature (NA1).