Customers may experience latency sending envelopes
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 09:15 UTC
Investigating
We are currently investigating this issue.
Posted Jan 24, 2023 - 06:45 UTC
This incident affected: eSignature (AU).