Some customers in Demo may have encountered latency or timeouts during signing between 14:30 and 14:34 UTC.
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Mar 23, 2023 - 17:43 UTC
Investigating
We are currently investigating this issue.
Posted Mar 23, 2023 - 17:43 UTC
This incident affected: eSignature (DEMO).