Some customers may experience issues logging into NA21
Incident Report for DocuSign
Resolved
This incident has been resolved as of 2:50 PM PST 3/30/2023
Posted Mar 30, 2023 - 22:12 UTC
Update
The fix was implemented and we're seeing improved metrics as of 2:48 PM PST
Posted Mar 30, 2023 - 22:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 30, 2023 - 22:07 UTC
Identified
We identified the issue and implemented a fix.
Posted Mar 30, 2023 - 21:48 UTC
Investigating
We are currently investigating this issue.
Posted Mar 30, 2023 - 21:30 UTC
This incident affected: CLM (NA21).