Customers in NA2 may experience issues using eSign (DIRCA-2299)

Incident Report for Docusign

Postmortem

RCA for NA2 eSignature Service Disruption on March 12, 2025

Impact Summary:

On March 12, 2025 between 02:54 PM UTC and 03:05 PM UTC, eSignature users may have experienced errors or high latency when attempting to sign in to their account, prepare or send documents for signature, sign documents or other functions related to eSignature.

Cause:

A routine database deployment resulted in an unexpected resource constraint to the applicable sub-processing system in NA2, causing a service interruption for affected customers.

Resolution:

The brief interruption to the database automatically recovered without intervention and resumed processing traffic.

Posted Mar 13, 2025 - 20:38 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-03-12 02:54 PM UTC until 2025-03-12 03:05 PM UTC.
Posted Mar 12, 2025 - 17:00 UTC

Monitoring

Customers may have experienced issues using eSign from 02:54 PM UTC - 03:05 PM UTC.
Posted Mar 12, 2025 - 15:15 UTC

Investigating

We are currently investigating this issue.
Posted Mar 12, 2025 - 15:04 UTC
This incident affected: eSignature (NA2).