Customers may experience latency or failures when signing in NA1 (DIRCA-3937)

Incident Report for Docusign

Postmortem

RCA for eSign NA1 Service Disruption on December 8, 2025

Impact Summary:

Between 09:41 AM and 11:45 AM UTC, a subset of customers utilizing the NA1 eSign environment experienced a disruption in service. Customers may have been unable to complete signing transactions or log in to the web interface.

Cause:

During a routine database failover operation, an unexpected configuration error surfaced on a load balancer. This error prevented user traffic from routing correctly to the necessary systems.

Resolution:

Our engineering team identified a networking misconfiguration and applied a correction. This fix restored traffic, bringing the signing service and web interface back online.

Posted Dec 09, 2025 - 11:50 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced latency or failures when signing in NA1 from 2025-12-08 09:41 AM UTC until 2025-12-08 11:45 AM UTC.
Posted Dec 08, 2025 - 12:38 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 08, 2025 - 11:55 UTC

Investigating

We are currently investigating this issue.
Posted Dec 08, 2025 - 11:22 UTC
This incident affected: eSignature (NA1).