Send Latency in EU (Incident 4776)

Incident Report for Docusign

Resolved

All telemetry is now reporting that this issue has been resolved.
Posted Apr 28, 2026 - 09:40 UTC

Monitoring

A fix has been implemented and engineers are now monitoring telemetry to validate.
Posted Apr 28, 2026 - 09:30 UTC

Identified

Engineers have identified a root cause and are working on releasing a fix.
Posted Apr 28, 2026 - 09:24 UTC

Investigating

A subset of customers in EU may experience latency with Send operations. Engineering teams have been engaged and are actively triaging.
Posted Apr 28, 2026 - 09:03 UTC
This incident affected: eSignature (EU).