Platform Latency in UAT (Incident 5187)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 25, 2026 - 13:01 UTC

Monitoring

Fix has been implemented and we are now monitoring telemetry to validate.
Posted Jun 25, 2026 - 10:27 UTC

Identified

We have identified the source of the issue and are preparing a fix.
Posted Jun 25, 2026 - 10:12 UTC

Investigating

Customers may be experiencing latency on the platform in the UAT Environment. Engineers have been engaged and are actively triaging this issue.
Posted Jun 25, 2026 - 08:44 UTC
This incident affected: CLM (UAT NA11).