Envelope Access Issues (DIRCA-3819)

Incident Report for Docusign

Resolved

The fix that our engineering team implemented was successful and all errors have now cleared.
Posted Nov 18, 2025 - 21:17 UTC

Monitoring

A fix has been implemented and we are now monitoring the results.
Posted Nov 18, 2025 - 21:01 UTC

Identified

We are currently investigating an issue where a small subset of EU customers cannot access sent envelopes or are receiving errors. Our team has identified the cause and is working on a fix.
Posted Nov 18, 2025 - 20:42 UTC
This incident affected: eSignature (EU).