Customers may experience signature errors or timeouts in the TSP Production environment (DIRCA-2725)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 06, 2025 - 14:31 UTC

Update

We are continuing to investigate this issue.
Posted Jun 06, 2025 - 14:30 UTC

Investigating

We are currently investigating this issue.
Posted Jun 06, 2025 - 14:29 UTC
This incident affected: TSP EU (EU Trusted Service Provider).