Some customers may be unable to switch accounts within the eSign web application or switch to CLM from the eSign web application (DIRCA-3739)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Nov 06, 2025 - 15:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2025 - 14:31 UTC

Investigating

We are currently investigating the issue
Posted Nov 06, 2025 - 11:36 UTC
This incident affected: eSignature (NA4, EU).