Customers intermittently experiencing issues utilizing DocuSign services in Multiple Environments (IM-39537)
Incident Report for Docusign
Postmortem

RCA for eSignature North America Service Disruption on February 27th, 2024

Impact Summary:

Some customers may have been unable to send envelopes during the affected time period.

Cause:

Due to a bug in a third-party tool used for feature management, an API version mismatch resulted in certain DocuSign features becoming unavailable for a subset of customers.

Resolution:

Following a manual modification in feature management tooling, the issue was resolved, and users regained the ability to send. Our internal processes have been updated to address the version mismatch issue. The third-party tool is also being updated to prevent this issue from occurring again.

Posted Feb 28, 2024 - 17:54 UTC

Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Feb 27, 2024 - 19:08 UTC
Update
The service is currently stable, with ongoing investigation into the root cause. Our teams are persistently monitoring the site's health during this period.
Posted Feb 27, 2024 - 18:19 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 17:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 17:30 UTC
Update
We are continuing to monitor for any further issues.
Posted Feb 27, 2024 - 17:26 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 27, 2024 - 17:14 UTC
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 16:42 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4).