CLM: Some users may experience issues accessing CLM or errors making calls to the Members API (DIRCA-3073)

Incident Report for Docusign

Postmortem

RCA for Production CLM Service Disruption on August 06, 2025

Impact Summary:

Between 2025-08-06 11:51 AM UTC and 2025-08-06 3:35 PM UTC, some users of CLM Production experienced login failures.

Cause:

A change deployed immediately prior to the incident introduced a bug that triggered excessive API calls causing an internal rate limiting circuit breaker to trip, affecting some login requests.

Resolution:

To resolve the issue, we rolled back the impacting change, which restored system performance. We have suspended deployments of the affecting service pending a review of the failure to ensure preventative measures are in place.

Posted Aug 08, 2025 - 00:51 UTC

Resolved

The incident has been resolved. If you still see an error please log out of your session and log back in. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-08-06 11:51 AM UTC until 2025-08-06 03:35 PM UTC.
Posted Aug 06, 2025 - 16:35 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 06, 2025 - 16:18 UTC

Update

We are continuing to investigate this issue.
Posted Aug 06, 2025 - 15:22 UTC

Update

Our teams continue to investigate this issue. Some users may experience issues accessing CLM or receive errors when making calls to the Members API.
Posted Aug 06, 2025 - 14:12 UTC

Update

We are continuing to investigate this issue.
Posted Aug 06, 2025 - 13:10 UTC

Investigating

We are currently investigating this issue.
Posted Aug 06, 2025 - 12:59 UTC
This incident affected: CLM (NA11, NA21, US11, EU11, EU21).