Intermittent Issues With Delivery of e-mail Notifications (Incident 5326)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jul 07, 2026 - 16:48 UTC

Identified

A subset of customers may experience intermittent failures of email notifications upon sending of envelopes. To mitigate this customers can log into their DocuSign account and access the envelope directly. Engineering teams have identified the issue and are currently working to resolve this issue.
Posted Jul 07, 2026 - 15:31 UTC
This incident affected: eSignature (AU, CA, EU, FedRAMP, JP1, NA1, NA2, NA3, NA4, DEMO).