NA21 CLM: Users may be unable to access content and execute reports (DIRCA-2787)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-06-13 11:30 PM UTC until 2025-06-14 03:35 AM UTC.
Posted Jun 14, 2025 - 05:25 UTC

Monitoring

A fix has been implemented which restores service for most requests, although access to some recently uploaded documents may still be impacted. We continue to work on restoring access to all content.
Posted Jun 14, 2025 - 02:42 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 14, 2025 - 02:20 UTC

Update

We are continuing to work on this issue. A fix is being deployed to resolve the problem.
Posted Jun 14, 2025 - 01:48 UTC

Identified

Some users may be experiencing errors when attempting to access content in their CLM account. We have identified the cause of the issue and are working on a resolution.
Posted Jun 14, 2025 - 01:19 UTC
This incident affected: CLM (NA21).