NA2 PROD eSign: Scheduled and Send Now reports may be delayed (DIRCA-3288)

Incident Report for Docusign

Resolved

Mitigation steps have been applied which has improved performance, though some report delays may still occur as processing time fluctuates. We will continue monitoring closely and are working on additional improvements to further optimize report delivery times.
Posted Sep 03, 2025 - 01:46 UTC

Monitoring

A change has been applied and we are seeing processing times improve. Users may still experience some delays in processing while the backlog of reports completes.
Posted Sep 02, 2025 - 19:58 UTC

Update

We are continuing to work on a fix for this issue.
Posted Sep 02, 2025 - 19:30 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 02, 2025 - 19:25 UTC

Investigating

We are currently investigating this issue.
Posted Sep 02, 2025 - 19:16 UTC
This incident affected: eSignature (NA2, EU).