Users may encounter errors when attempting to process envelopes (Incident 5072)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 11, 2026 - 21:50 UTC

Investigating

We are investigating this issue.
Posted Jun 11, 2026 - 19:45 UTC
This incident affected: eSignature (DEMO).