Slow performance and delays for Agreement Manager, CLM, and eSign (Incident 5674)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation. Customers may have experienced errors from 2026-08-27 11:27 PM UTC until 2026-08-28 01:18 AM UTC.
Posted Aug 28, 2026 - 01:49 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2026 - 01:27 UTC

Update

The issue has been identified and we continue our work to implement a fix.
Posted Aug 28, 2026 - 00:25 UTC

Identified

We have identified the underlying cause and are working to implement a fix.
Posted Aug 28, 2026 - 00:04 UTC

Investigating

We are investigating delays across the site.
Posted Aug 27, 2026 - 23:39 UTC
This incident affected: eSignature (AU, CA).