Unable to Preview Documents in Navigator (DIRCA-3837)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have been unable to preview or download documents in Navigator from 2025-11-19 08:00 PM UTC until 2025-11-19 11:28 PM UTC.
Posted Nov 19, 2025 - 23:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2025 - 23:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 19, 2025 - 22:28 UTC

Update

Engineering teams have implemented a fix and are currently reviewing our telemetry to ensure mitigation.
Posted Nov 19, 2025 - 22:21 UTC

Identified

Engineers have identified a potential fix and are currently prepping this for release.
Posted Nov 19, 2025 - 21:27 UTC

Investigating

Customers may be unable to preview documents using the Navigator product. Engineering teams are currently triaging this issue in order to restore this functionality.
Posted Nov 19, 2025 - 21:19 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4).