Document Upload and Generation Errors (Incident 5073)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jun 11, 2026 - 23:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2026 - 22:13 UTC

Identified

We have identified the issue and a fix is being implemented.
Posted Jun 11, 2026 - 22:05 UTC

Update

We continue to investigate the issue.
Posted Jun 11, 2026 - 21:52 UTC

Update

We continue to investigate the issue and additional resources have been engaged.
Posted Jun 11, 2026 - 20:34 UTC

Update

We continue to investigate the issue and additional resources have been engaged.
Posted Jun 11, 2026 - 20:19 UTC

Update

We are continuing to investigate this issue.
Posted Jun 11, 2026 - 19:49 UTC

Investigating

We are actively investigating this issue.
Posted Jun 11, 2026 - 19:03 UTC
This incident affected: CLM (NA11, NA21, S1.US) and eSignature (NA2, NA4).