NA PROD eSign: Users may experience latency when sending and signing (DIRCA-3298)

Incident Report for Docusign

Postmortem

RCA for NA1, NA2, NA4 eSign Service Disruption on September 3, 2025

Impact Summary:

Some users across some North American eSign sites may have experienced latency and errors when attempting to send documents for signature or sign documents. The impacted time windows are noted below:

  • NA2: 2025-09-03 02:04 PM UTC to 2025-09-03 02:48 PM UTC
  • NA1, NA4: 2025-09-03 02:35 PM UTC to 2025-09-03 03:24 PM UTC

Cause:

A recent change to an asynchronous processing job, responsible for notifications, inadvertently increased the load on a backend storage layer. This caused a performance degradation within the storage service, impacting the send and sign user experience.

Resolution:

To quickly restore service to impacted customers, affected servers were restarted to reduce resource utilization. To address the risk of recurrence, the following actions are being taken to reduce the load on the storage system:

  1. The frequency of the asynchronous processing job which triggered the issue has been reduced, reducing the load on the impacted backend system.
  2. Additional capacity is being added to the storage system.
  3. Health monitoring of the backend storage system has been improved to provide earlier indication of a problem to our Engineering team.
Posted Sep 04, 2025 - 23:02 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-09-03 02:04 PM UTC until 2025-09-03 03:24 PM UTC.
Posted Sep 03, 2025 - 15:56 UTC

Monitoring

A fix has been implemented and the issue is now mitigated. We are continuing to monitor service health prior to resolving this incident.
Posted Sep 03, 2025 - 15:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2025 - 15:08 UTC

Update

We are continuing to investigate this issue.
Posted Sep 03, 2025 - 14:49 UTC

Investigating

We are currently investigating this issue.
Posted Sep 03, 2025 - 14:46 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4).