A Subset of Customers May Experience Intermittent Latency When Sending or Receiving (Incident-4356)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Feb 17, 2026 - 15:51 UTC

Investigating

A subset of customers may be experiencing intermittent latency on executing send and receive jobs. Our engineering teams are engaged on this and are actively triaging.
Posted Feb 17, 2026 - 14:57 UTC
This incident affected: eSignature (NA1, NA3).