eSign Demo: Some users may experience issues uploading documents while using Firefox or Safari (DIRCA-2580)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted May 12, 2025 - 12:12 UTC

Update

Our teams are actively investigating this issue. We will provide an update once a resolution is identified. In the meantime, as a workaround, please use Chrome or Edge in the demo environment.
Posted May 12, 2025 - 11:15 UTC

Investigating

We are currently investigating this issue.
Posted May 12, 2025 - 10:56 UTC
This incident affected: eSignature (DEMO).