Customers in NA2 and NA3 may be experiencing errors in using eSign (DIRCA-2142)

Incident Report for Docusign

Postmortem

Impact Summary:

Between 06:56 PM UTC and 08:27 PM UTC Feb 05, 2025, Docusign eSignature NA2 and NA3 customers experienced a service impact.  Some users were unable to log in, sign or send envelopes for signature, or may have experienced significant latency in conducting these operations.

Cause:

An unexpected interruption to our database systems resulted after a routine change, impacting core eSignature product functionality.

Once service degradation was detected, the team promptly began efforts to mitigate impact and restore system performance.

Resolution:

The incident was mitigated by failing over to a secondary server, which allowed a backlog of operations to clear and recover to a known good state.  We are reviewing procedures related to the impacting change and have also scheduled non-critical operations to off-business hours to prevent a recurrence.

Posted Feb 06, 2025 - 23:17 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-02-05 06:56 PM UTC until 2025-02-05 08:27 PM UTC.
Posted Feb 05, 2025 - 22:14 UTC

Monitoring

At this time, this issue has been mitigated on NA2 and NA3 and services have returned to normal performance. The team continues to actively monitor.
Posted Feb 05, 2025 - 20:49 UTC

Identified

The team has taken steps to mitigate impact and we are seeing significant improvement. Users may still see impact to some functions.
Posted Feb 05, 2025 - 20:18 UTC

Update

We are continuing to investigate this issue.
Posted Feb 05, 2025 - 19:31 UTC

Update

NA2 and NA3 sites are now available, however users are experiencing latency. The team continues to investigate and work on restoring normal service levels.
Posted Feb 05, 2025 - 19:31 UTC

Investigating

We are currently investigating this issue.
Posted Feb 05, 2025 - 19:08 UTC
This incident affected: eSignature (NA2, NA3).