Customers in AU/JP may experience errors or delays when logging in, sending, or signing envelopes (Incident 5409)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Posted Jul 23, 2026 - 22:30 UTC

Update

AU and JP are stable at present. Teams are continuing to investigate the issue.
Posted Jul 23, 2026 - 21:45 UTC

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 21:07 UTC

Investigating

We are actively investigating this issue.
Posted Jul 23, 2026 - 20:59 UTC
This incident affected: eSignature (AU, JP1).