eSign customers may be unable to access Knowledge-Based Authentication (DIRCA-1958)
Incident Report for Docusign
Resolved
The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2024-11-27 10:40 PM UTC until 2024-11-28 01:22 AM UTC
Posted Nov 28, 2024 - 01:51 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 28, 2024 - 00:36 UTC
Identified
We have identified the cause and are working with a 3rd party provider to resolve the issue.
Posted Nov 28, 2024 - 00:05 UTC
Investigating
We are currently investigating this issue.
Posted Nov 27, 2024 - 23:46 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, DEMO) and Notary.