Intermittent Latency on NA11 (DIRCA-3486)

Incident Report for Docusign

Resolved

No further issues have been observed during the monitoring period.
Posted Sep 30, 2025 - 16:48 UTC

Monitoring

A fix has been implemented and we are seeing improvements in our telemetry. Teams will continue to monitor.
Posted Sep 30, 2025 - 16:01 UTC

Identified

Engineers have identified a potential cause for this issue and are applying a fix.
Posted Sep 30, 2025 - 15:33 UTC

Investigating

A small subset of customers in NA11 may experience intermittent latency while attempting to use the CLM API. Our engineering teams are currently engaged and actively triaging the cause of this impact.
Posted Sep 30, 2025 - 15:18 UTC
This incident affected: CLM (NA11).