Customers may see inaccurate statuses of envelopes (IM-39711)
Incident Report for DocuSign
Postmortem

RCA for eSign Service Disruption on April 12, 2024

Impact Summary:

eSignature customers may have experienced delays in search results and reports, and envelopes may have appeared missing post-transfer or in “manage” tabs during the affected time period.

‌Cause:

Due to a bug, the data replication service underlying our discovery capabilities experienced an issue which prevented the system from processing the data required to surface envelopes in the affected functionalities. No underlying data was impacted or lost during this time period.

Resolution:

The data replication service was restarted, restoring functionality.

Posted Apr 17, 2024 - 01:25 UTC

Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Apr 12, 2024 - 16:38 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 12, 2024 - 16:16 UTC
Update
Recovery is underway, an update will be provided shortly.
Posted Apr 12, 2024 - 16:04 UTC
Identified
The team has identified the issue and is working to remediate it. Customers may see a delay in search results and reports, and envelopes may appear missing post-transfer or in manage tabs.
Posted Apr 12, 2024 - 15:47 UTC
Investigating
We are currently investigating the issue.
Posted Apr 12, 2024 - 15:17 UTC
This incident affected: eSignature (NA4).