Customers may see errors when logging into ESign (DIRCA-2334)

Incident Report for Docusign

Postmortem

RCA for eSignature Service Disruption on March 19, 2025

Impact Summary:

During the impacted window, some users were unable to login, send documents for signature, sign documents, or perform other related functions in the web user interface. Actions performed using the API were unaffected.

Cause:

Between 2025-03-19 03:16 AM UTC and 2025-03-19 08:32 AM UTC the Docusign entry gateway was the target of a Denial of Service Attack. The attack overwhelmed our application servers, consuming all resources and preventing normal application traffic from being processed.

Although users were unable to access the site during the attack, there is no indication that this event involved any data loss or corruption.

Resolution:

To mitigate impact and restore service, we implemented temporary rate limits.

Posted Mar 21, 2025 - 16:05 UTC

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-03-19 03:16 AM UTC until 2025-03-19 08:32 AM UTC.
Posted Mar 19, 2025 - 08:44 UTC

Identified

The issue has been identified. The team are working on a fix. Additionally, customers may experience issues with signing documents.
Posted Mar 19, 2025 - 07:45 UTC

Update

We are continuing to investigate this issue.
Posted Mar 19, 2025 - 06:13 UTC

Investigating

We are currently investigating this issue.
Posted Mar 19, 2025 - 06:09 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU).