AU ESign customers may have experienced a disruption in services.
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Mar 27, 2023 - 13:01 UTC
Investigating
We are currently investigating this issue.
Posted Mar 27, 2023 - 12:57 UTC
This incident affected: eSignature (AU).