Customers may experience timeouts related to core AI features which include document summarization and extractions. (incident 4961)

Incident Report for Docusign

Identified

The issue has been identified and a fix is being implemented.
Posted May 27, 2026 - 04:03 UTC

Investigating

We are continuing to investigate this issue.
Posted May 27, 2026 - 03:32 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 27, 2026 - 02:35 UTC

Investigating

We are currently investigating this issue.
Posted May 27, 2026 - 01:04 UTC
This incident affects: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU, DEMO, JP).