Esign Users in Norway, Finland, Belgium, Sweden, Denmark, Netherlands may see an error when verifying identity, due to an outage at a third party identity verification vendor. (IM-39552)
Incident Report for DocuSign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.
Posted Mar 02, 2024 - 10:11 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 02, 2024 - 05:39 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 02, 2024 - 02:49 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 01, 2024 - 22:33 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 01, 2024 - 19:20 UTC
Update
Performance from the third party identity verification vendor continues to be good.
Posted Mar 01, 2024 - 15:40 UTC
Monitoring
The identity verification vendor mitigated the issue on their service. The issue is now mitigated. We will continue to monitor performance.
Posted Mar 01, 2024 - 15:14 UTC
Update
The third party identity verification vendor is continuing to work on resolving the issue.
Posted Mar 01, 2024 - 11:42 UTC
Identified
The third party identity verification vendor is working to resolve the issue.
Posted Mar 01, 2024 - 10:15 UTC
This incident affected: eSignature (EU).