Customers may experience issues accessing PowerForms (Incident 4870)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.
Some customers may have experienced issues accessing PowerForms from 2026-05-12 05:22 PM UTC until 2026-05-12 07:59 PM UTC.
Posted May 12, 2026 - 20:03 UTC

Investigating

We are currently investigating this issue.
Posted May 12, 2026 - 19:41 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU, JP).