PROD eSign: Admin users may be unable to edit some sharing options (DIRCA-2525)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-04-23 12:00 AM UTC until 2025-05-7 11:20 PM UTC.
Posted May 08, 2025 - 15:40 UTC

Update

We are continuing to monitor for further issues. The next update will be tomorrow morning.
Posted May 08, 2025 - 05:32 UTC

Monitoring

A fix has been implemented and we are verifying the results.
Posted May 07, 2025 - 23:44 UTC

Update

We have made a number of change and are seeing some improvements, but are not yet fully recovered. We continue to work on returning to normal performance of the 'Edit on behalf of' and 'Send on behalf of' Admin functions. Next update will be by end of day.
Posted May 07, 2025 - 03:06 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 07, 2025 - 00:41 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 06, 2025 - 17:37 UTC

Investigating

We continue to actively investigate the issue and have made progress in narrowing down the cause.
Posted May 06, 2025 - 16:00 UTC

Monitoring

A fix has been implemented and we are monitoring the results. The next update will be in a few hours.
Posted May 06, 2025 - 05:00 UTC

Update

We continue to actively investigate the issue and have made progress in narrowing down the cause.
Posted May 06, 2025 - 02:57 UTC

Update

We are continuing to investigate this issue.
Posted May 06, 2025 - 01:25 UTC

Investigating

We are currently investigating reports that Admin users are unable to grant 'Edit on behalf of' and 'Send on behalf of' sharing options.
Posted May 06, 2025 - 00:42 UTC
This incident affected: eSignature (NA2, AU, EU).