User Membership Group Update Delays (Incident 4672)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced delays from 2026-04-09 04:24 AM UTC until 2026-04-09 09:22 PM UTC.
Posted Apr 09, 2026 - 21:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2026 - 21:01 UTC

Update

We are implementing a change to resolve the AU delay.
Posted Apr 09, 2026 - 20:39 UTC

Update

NA1 is now back to normal operational expectations. We are working to resolve the issue in AU now.
Posted Apr 09, 2026 - 19:56 UTC

Identified

Changes to user membership groups is significantly delayed. We are making changes to reduce or remove the delay.
Posted Apr 09, 2026 - 19:40 UTC
This incident affected: eSignature (NA1, AU).