Prod: Users may may have experienced errors across eSign, CLM, Rooms (DIRCA-2956)

Incident Report for Docusign

Resolved

The incident has been resolved. If users still experience errors, please log out of the application and log back in.

eSign users may have experienced errors logging in or sending documents for signature. CLM users who authenticate using the eSign site may have experienced errors. Rooms users were unable to gain access to Rooms or app admin during the incident period.

Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2025-07-18 06:31 PM UTC until 2025-07-18 07:23 PM UTC.
Posted Jul 18, 2025 - 19:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 19:27 UTC

Investigating

We are currently investigating this issue.
Posted Jul 18, 2025 - 19:19 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4, CA, AU, EU).