Some customers may see degradation in Workflow execution [IM-39678]
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Apr 06, 2024 - 01:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 06, 2024 - 01:33 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 06, 2024 - 01:25 UTC
This incident affected: CLM (NA11).