Some customers may experience intermittent errors retrieving envelopes (DIRCA-1781)
Incident Report for Docusign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.

Some customers may have experienced intermittent errors from 2024-10-02 17:11UTC until 2024-10-02 18:16UTC.
Posted Oct 02, 2024 - 18:30 UTC
Investigating
We are currently investigating this issue.
Posted Oct 02, 2024 - 18:06 UTC
This incident affected: eSignature (AU).