Issues in UAT and DEMO S1 when attempting to complete tasks in task groups (Incident 4591)

Incident Report for Docusign

Resolved

The incident has been resolved. Incident duration and timelines are subject to revision pending the results of any related investigation.

Customers may have experienced issues from 2026-03-27 12:32 AM UTC until 2026-03-27 11:30 PM UTC
Posted Mar 27, 2026 - 23:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 27, 2026 - 22:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2026 - 21:00 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2026 - 17:22 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 27, 2026 - 16:21 UTC

Update

Engineers are continuing to triage and develop a fix to the identified issue.
Posted Mar 27, 2026 - 15:42 UTC

Identified

A potential cause has been identified, engineering teams are reproducing the issue and reviewing telemetry before applying a fix.
Posted Mar 27, 2026 - 14:59 UTC

Update

More engineering teams have been engaged to triage this error and investigation is continuing.
Posted Mar 27, 2026 - 14:26 UTC

Investigating

Due to a recently identified issue in our UAT environments, tasks may be routed incorrectly, leading to failures. Our team is actively working on identifying the root cause and mitigating it, and we will keep you updated as progress is made. Please note that any workflows and tasks on your Production environment should not be affected, and will still be executed normally.
Posted Mar 27, 2026 - 12:41 UTC
This incident affected: CLM (UAT NA11, DEMO S1).