Customers may see increased latency when sending and signing and intermittent errors (Incident 5232)

Incident Report for Docusign

Update

The issue has been identified and we continue our work to implement a fix.
Posted Jun 29, 2026 - 17:16 UTC

Identified

We have identified the issue and a fix is being implemented.
Posted Jun 29, 2026 - 17:07 UTC

Update

We are continuing to investigate this issue.
Posted Jun 29, 2026 - 17:05 UTC

Investigating

We are actively investigating this issue.
Posted Jun 29, 2026 - 15:30 UTC
This incident affects: CLM (NA11, NA21, S1.US, S2.US) and eSignature (NA1, NA2, NA3, NA4).