On September 1, this site will be replaced by health.docusign.com/status.
To continue getting notifications, you'll need to resubscribe on the new site.
View detailed instructions here.
Further monitoring has concluded that the fix implemented by our engineering teams has resolved this incident.
Posted Aug 11, 2026 - 06:50 UTC
Monitoring
Our engineering teams have deployed a fix to the affected environments and we are monitoring our telemetry to validate.
Posted Aug 11, 2026 - 05:46 UTC
Identified
Our engineering teams have identified the potential cause of this issue and we are in the process of deploying a fix.
Posted Aug 11, 2026 - 05:01 UTC
Investigating
Some customers may be experiencing issues when attempting to sign in to Docusign in the AU region. Engineering teams have been engaged and we are actively triaging this issue.
Posted Aug 11, 2026 - 04:49 UTC
This incident affected: eSignature (AU, CA, EU, JP1, NA1, NA2, NA3, NA4).