Customers are unable to access Apps and Keys section within the Esign admin Tool and Developer Center Tool (DIRCA-1763)
Incident Report for Docusign
Resolved
The incident has been resolved. Outage duration and incident timelines are subject to revision pending the results of any related investigation.

Customers may have experienced errors from 2024-09-27 02:48UTC until 2024-09-27 04:36UTC.
Posted Sep 27, 2024 - 04:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 27, 2024 - 03:54 UTC
This incident affected: eSignature (DEMO).