3RD Party IDV Provider Interruption to Service Caused Intermittent Issues for DocuSign (IM-39759)
Incident Report for DocuSign
Resolved
This incident has been resolved.
Posted Apr 25, 2024 - 17:47 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2024 - 17:33 UTC
Monitoring
The 3RD Party IDV Provider restored functionality. We are monitoring the results.
Posted Apr 25, 2024 - 17:21 UTC
Investigating
We are currently investigating this issue.
Posted Apr 25, 2024 - 17:20 UTC
This incident affected: eSignature (EU).