NA1/NA2/NA3/NA4 Agreement Desk Customers may experience issues creating or viewing tickets (DIRCA-4204)

Incident Report for Docusign

Resolved

The issue impacting Agreement Desk has been resolved, and normal service has been restored.

Customers should now be able to create tickets and view newly created tickets and recent updates as expected.
Posted Jan 26, 2026 - 19:42 UTC

Investigating

We are investigating an issue impacting Agreement Desk in NA1 - NA4.

Some customers may experience problems creating tickets, or may not see newly created tickets or recent updates appear as expected. Our teams are actively working to identify the cause and restore normal service.

We will share updates as more information becomes available.
Posted Jan 26, 2026 - 19:37 UTC
This incident affected: eSignature (NA1, NA2, NA3, NA4).